OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-1232

Workflows in RuleManager broken after bin/stop ing openengsb

    Details

      Description

      Workaround for this (in case someone else experiences this): Overwrite old Workflows at startup of your app (e.g. RuleManager.addOrUpdate() until this is fixed

        Gliffy Diagrams

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Michael Petritsch created issue -
          Michael Petritsch added a comment -

          to reproduce the bug create an app that adds a workflow to the openengsb (RuleManager.add(RuleBaseElementType.Process, WORKFLOW_ID)).
          now you should be able to start the workflow with WorkflowService.startFlow(WORKFLOW_ID).
          stop karaf.
          start it again.
          do a ruleManager.get(new RuleBaseElementId(RuleBaseElementType.Process, WORKFLOW_ID)).
          it should still contain your workflow.
          but WorkflowService.startFlow(WORKFLOW_ID) should fail.

          Andreas Pieber made changes -
          Field Original Value New Value
          Component/s openengsb-framework [ 10140 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.3 [ 10660 ]
          Fix Version/s framework-2.5.0 [ 10596 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Affects Version/s framework-2.4.2 [ 10621 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.4 [ 10761 ]
          Fix Version/s framework-2.4.3 [ 10660 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.5 [ 10764 ]
          Fix Version/s framework-2.4.4 [ 10761 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.1 [ 10771 ]
          Fix Version/s framework-2.6.0 [ 10763 ]
          Fix Version/s framework-2.5.0 [ 10596 ]
          Fix Version/s framework-2.4.5 [ 10764 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.2 [ 10860 ]
          Fix Version/s framework-2.5.1 [ 10771 ]
          Lukas Stampf made changes -
          Assignee Lukas Stampf [ l.stampf ]
          Andreas Pieber made changes -
          Workflow jira [ 12002 ] OpenEngSB Workflow [ 15770 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.2 [ 10860 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.6.0 [ 10763 ]
          Lukas Stampf added a comment -

          I guess this should have been fixed when adding persistence to the rulemanager. I wont do an additional test since I am currently removing the Rulemanager

          Lukas Stampf made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Won't Fix [ 2 ]
          Lukas Stampf made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Andreas Pieber made changes -
          Labels archived
          Stefan Scheiber made changes -
          Workflow OpenEngSB Workflow [ 15770 ] OpenEngSB 2 Workflow [ 22278 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0.M1 [ 11164 ]
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Assignee Time in statuses
          Lukas Stampf
          The issue is open and ready for the assignee to start work on it.Open
          12/Sep/12 16:02 - 03/Jan/13 14:43 : 2711 h, 41 m
          Total: 2711 h, 41 m
          A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
          03/Jan/13 14:43 - 03/Jan/13 14:43 : 6 s
          Total: 6 s
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          03/Jan/13 14:43 - Today 23:16 : 41407 h, 33 m
          Total: 41407 h, 33 m
          unknown
          The issue is open and ready for the assignee to start work on it.Open
          05/Apr/11 20:04 - 12/Sep/12 16:02 : 12619 h, 57 m
          Total: 12619 h, 57 m
          Status Time from assignees
          The issue is open and ready for the assignee to start work on it.Open
          Lukas Stampf
          12/Sep/12 16:02 - 03/Jan/13 14:43 : 2711 h, 41 m
          Total: 2711 h, 41 m
          unknown
          05/Apr/11 20:04 - 12/Sep/12 16:02 : 12619 h, 57 m
          Total: 12619 h, 57 m
          A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
          Lukas Stampf
          03/Jan/13 14:43 - 03/Jan/13 14:43 : 6 s
          Total: 6 s
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          Lukas Stampf
          03/Jan/13 14:43 - Today 23:16 : 41407 h, 33 m
          Total: 41407 h, 33 m

            People

            • Assignee:
              Lukas Stampf
              Reporter:
              Michael Petritsch
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: