OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-1769

mvn eclipse:eclipse does not include html-files in build-path of ui-admin and ui-common

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: framework-1.3.0.M3
    • Fix Version/s: openengsb-3.0.0
    • Component/s: framework
    • Labels:
      None

      Description

      After running mvn eclipse:eclipse the source-folder entries for src/main/java and src/test/java only include .java-files?
      Anyone else experiencing this issue?

        Gliffy Diagrams

        Error rendering 'com.meetme.plugins.jira.gerrit-plugin:gerritreviewsmodule'. Please contact your JIRA administrators.

          Activity

          Hide
          Andreas Pieber added a comment -

          I'm afraid I have to confirm this bug; see the .classpath in admin for example:

            <classpathentry kind="src" path="src/test/java" output="target/test-classes" including="**/*.java"/>
            <classpathentry kind="src" path="src/test/resources" output="target/test-classes" excluding="**/*.java"/>
            <classpathentry kind="src" path="src/main/java" including="**/*.java"/>
            <classpathentry kind="src" path="src/main/resources" including="**/**.*" excluding="**/*.java"/>

          Since they are imported correctly in mvn I would guess that it is the fault of the mvn eclipse plugin. Now we simply have to find out y...

          Show
          Andreas Pieber added a comment - I'm afraid I have to confirm this bug; see the .classpath in admin for example: <classpathentry kind="src" path="src/test/java" output="target/test-classes" including="**/*.java"/> <classpathentry kind="src" path="src/test/resources" output="target/test-classes" excluding="**/*.java"/> <classpathentry kind="src" path="src/main/java" including="**/*.java"/> <classpathentry kind="src" path="src/main/resources" including="**/**.*" excluding="**/*.java"/> Since they are imported correctly in mvn I would guess that it is the fault of the mvn eclipse plugin. Now we simply have to find out y...
          Hide
          Andreas Pieber added a comment -

          mhm... where exactly does this create problems?

          Show
          Andreas Pieber added a comment - mhm... where exactly does this create problems?
          Hide
          Christoph Gritschenberger added a comment -

          well, you can't run the unit-tests in eclipse with the wrong config.
          Fixing the config manually is kind of annoying.

          Show
          Christoph Gritschenberger added a comment - well, you can't run the unit-tests in eclipse with the wrong config. Fixing the config manually is kind of annoying.
          Hide
          Andreas Pieber added a comment -

          this sounds like a configuration error somehow... someone has to give a shot the resource sections in the poms. BTW, does this only affects the master?

          Show
          Andreas Pieber added a comment - this sounds like a configuration error somehow... someone has to give a shot the resource sections in the poms. BTW, does this only affects the master?
          Hide
          Christoph Gritschenberger added a comment - - edited

          added a workaround-script in master

          Show
          Christoph Gritschenberger added a comment - - edited added a workaround-script in master
          Hide
          Andreas Pieber added a comment -

          don't we want to add this also to the 2.x.y and 2.0.x branch?

          Show
          Andreas Pieber added a comment - don't we want to add this also to the 2.x.y and 2.0.x branch?

            People

            • Assignee:
              Unassigned
              Reporter:
              Christoph Gritschenberger
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated: