OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-1858

Not all tests run green if another karaf instance is running

    Details

    • Sprint:
      Sprint 4

      Description

      Tests fail on the build-server for quite some time now.
      This is because somehow the HTML-unit-tests do not work because the web-ui can't be reached.

      It works when no other karaf is running. Although itests should open the web-ui on port 8091 (as port 8090 is blocked by opencit) the itests get a HTTP500

      In addition those itests are not the only once failing. There are even some "unit" tests which are failing if another instance of karaf is running. Since the tests are quite a bunch and need a lot of time this issue is considered quite critical since it limits the number of work you can do besides a ongoing test-run.

      A possible solution (I think) could be to use the maven-helper-plugin to configure the ports used in the tests [1].

      [1] http://mojo.codehaus.org/build-helper-maven-plugin/reserve-network-port-mojo.html

        Gliffy Diagrams

        Error rendering 'com.meetme.plugins.jira.gerrit-plugin:gerritreviewsmodule'. Please contact your JIRA administrators.

          Activity

          Christoph Gritschenberger created issue -
          Andreas Pieber added a comment -

          if you run them side by side. Is there anything interesting in the log file pointing out why openengsb itests does not come up?

          Christoph Gritschenberger added a comment -

          Just the usual about JMX failing to start up because of ports in use (1099, 44444)

          Andreas Pieber made changes -
          Field Original Value New Value
          Component/s framework [ 10140 ]
          Andreas Pieber added a comment -

          maybe we should rename the issue to something like: to openengsb instances could not run side by side

          Andreas Pieber made changes -
          Fix Version/s framework-2.4.3 [ 10660 ]
          Fix Version/s framework-2.5.0 [ 10596 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Affects Version/s framework-2.4.2 [ 10621 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.4 [ 10761 ]
          Fix Version/s framework-2.4.3 [ 10660 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.5 [ 10764 ]
          Fix Version/s framework-2.4.4 [ 10761 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.1 [ 10771 ]
          Fix Version/s framework-2.6.0 [ 10763 ]
          Fix Version/s framework-2.4.5 [ 10764 ]
          Fix Version/s framework-2.5.0 [ 10596 ]
          Andreas Pieber made changes -
          Summary itests fail when opencit is running Not all tests run green if another karaf instance is running
          Description Tests fail on the build-server for quite some time now.
          This is because somehow the HTML-unit-tests do not work because the web-ui can't be reached.
          It works when no other karaf is running. Although itests should open the web-ui on port 8091 (as port 8090 is blocked by opencit) the itests get a HTTP500
          Tests fail on the build-server for quite some time now.
          This is because somehow the HTML-unit-tests do not work because the web-ui can't be reached.

          It works when no other karaf is running. Although itests should open the web-ui on port 8091 (as port 8090 is blocked by opencit) the itests get a HTTP500

          In addition those itests are not the only once failing. There are even some "unit" tests which are failing if another instance of karaf is running. Since the tests are quite a bunch and need a lot of time this issue is considered quite critical since it limits the number of work you can do besides a ongoing test-run.

          A possible solution (I think) could be to use the maven-helper-plugin to configure the ports used in the tests [1].

          [1] http://mojo.codehaus.org/build-helper-maven-plugin/reserve-network-port-mojo.html
          Andreas Pieber made changes -
          Priority Major [ 3 ] Critical [ 2 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.2 [ 10860 ]
          Fix Version/s framework-2.5.1 [ 10771 ]
          Christoph Gritschenberger made changes -
          Rank Ranked higher
          Andreas Pieber made changes -
          Rank Ranked higher
          Andreas Pieber made changes -
          Sprint Sprint 4 [ 4 ]
          Andreas Pieber made changes -
          Assignee Lukas Stampf [ l.stampf ]
          Andreas Pieber added a comment -

          should be fixed; just try if it works

          Lukas Stampf added a comment -

          Started an openengsb instance and run the pre-push script in a 2nd terminal successfully. Confirmed as working.

          Lukas Stampf made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Lukas Stampf made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Andreas Pieber made changes -
          Workflow jira [ 12652 ] OpenEngSB Workflow [ 16247 ]
          Andreas Pieber made changes -
          Labels archived
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.2 [ 10860 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.6.0 [ 10763 ]
          Stefan Scheiber made changes -
          Workflow OpenEngSB Workflow [ 16247 ] OpenEngSB 2 Workflow [ 21012 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0.M1 [ 11164 ]
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Assignee Time in statuses
          Lukas Stampf
          The issue is open and ready for the assignee to start work on it.Open
          25/Jul/12 13:38 - 30/Jul/12 23:01 : 129 h, 23 m
          Total: 129 h, 23 m
          A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
          30/Jul/12 23:01 - 30/Jul/12 23:04 : 3 m
          Total: 3 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          30/Jul/12 23:04 - Today 12:19 : 46646 h, 14 m
          Total: 46646 h, 14 m
          unknown
          The issue is open and ready for the assignee to start work on it.Open
          28/Jul/11 15:19 - 25/Jul/12 13:38 : 8710 h, 19 m
          Total: 8710 h, 19 m
          Status Time from assignees
          The issue is open and ready for the assignee to start work on it.Open
          Lukas Stampf
          25/Jul/12 13:38 - 30/Jul/12 23:01 : 129 h, 23 m
          Total: 129 h, 23 m
          unknown
          28/Jul/11 15:19 - 25/Jul/12 13:38 : 8710 h, 19 m
          Total: 8710 h, 19 m
          A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
          Lukas Stampf
          30/Jul/12 23:01 - 30/Jul/12 23:04 : 3 m
          Total: 3 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          Lukas Stampf
          30/Jul/12 23:04 - Today 12:19 : 46646 h, 14 m
          Total: 46646 h, 14 m

            People

            • Assignee:
              Lukas Stampf
              Reporter:
              Christoph Gritschenberger
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile