OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-1858

Not all tests run green if another karaf instance is running

    Details

    • Sprint:
      Sprint 4

      Description

      Tests fail on the build-server for quite some time now.
      This is because somehow the HTML-unit-tests do not work because the web-ui can't be reached.

      It works when no other karaf is running. Although itests should open the web-ui on port 8091 (as port 8090 is blocked by opencit) the itests get a HTTP500

      In addition those itests are not the only once failing. There are even some "unit" tests which are failing if another instance of karaf is running. Since the tests are quite a bunch and need a lot of time this issue is considered quite critical since it limits the number of work you can do besides a ongoing test-run.

      A possible solution (I think) could be to use the maven-helper-plugin to configure the ports used in the tests [1].

      [1] http://mojo.codehaus.org/build-helper-maven-plugin/reserve-network-port-mojo.html

        Gliffy Diagrams

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

            People

            • Assignee:
              Lukas Stampf
              Reporter:
              Christoph Gritschenberger
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile