Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: openengsb-3.0.0.M2
    • Component/s: framework
    • Labels:
      None

      Description

      The problem here is that activemqweb starts but it does not work if you point your browser to it. In 1.2.x it still works?!

      This might not be a blocker for M4, but definitely is one for the 1.3.0 final release

        Gliffy Diagrams

        Error rendering 'com.meetme.plugins.jira.gerrit-plugin:gerritreviewsmodule'. Please contact your JIRA administrators.

          Activity

          Andreas Pieber created issue -
          Andreas Pieber made changes -
          Field Original Value New Value
          Fix Version/s openengsb-2.1.0 [ 10168 ]
          Fix Version/s framework-2.0.0 [ 10333 ]
          Christoph Gritschenberger made changes -
          Fix Version/s openengsb-2.1.0 [ 10168 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.1.0 [ 10489 ]
          Andreas Pieber made changes -
          Assignee Felix Mayerhuber [ arcticwolf ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.0.1 [ 10497 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.0.2 [ 10505 ]
          Fix Version/s framework-2.0.1 [ 10497 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.0.3 [ 10507 ]
          Fix Version/s framework-2.0.2 [ 10505 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.0.4 [ 10508 ]
          Fix Version/s framework-2.0.3 [ 10507 ]
          Felix Mayerhuber added a comment -

          sorted it out. If aries jndi bundle is started, the activemq web console doesn't work. I try if the EDB can run without it.

          Andreas Pieber added a comment -

          is this a problem with some double exports? I'm afraid that we'll have other problems (e.g. jpa) which is relying on the jndi bundle... mhm...

          Felix Mayerhuber added a comment -

          I don't know exactly whats the problem is. But we can't remove the bundle because jpa doesn't work without it

          Andreas Pieber added a comment -

          I was afraid of this... can we produce a VERY minimal example? I would like to point the right ppl on this but for that I'll need a simple example. Would this be possible?

          Felix Mayerhuber added a comment -

          you mean a little example project?

          Andreas Pieber added a comment -

          yep; best something very simple without openengsb context; there don't need to be JPA in the context; it's enough if the amq libs and the JNDI lib

          Felix Mayerhuber added a comment -

          wouldn't it be sufficient to take the aries jpa example and add the amq libs there? or is that too big?

          Andreas Pieber added a comment -

          would be perfect if it works

          Felix Mayerhuber added a comment -

          looks like this problem is already known

          https://issues.apache.org/jira/browse/ARIES-554

          but there is no information when this will be fixed in the aries jndi bundle

          Felix Mayerhuber added a comment -

          the problem is already fixed in the github repo. I will ask when the release of the next JNDI bundle version is planned

          Andreas Pieber added a comment -

          good to know I think this is a candidate for the known issue page on the HP (once it is in place). Till those aries packages are in karaf we cant do anything. Thanks for finding the problem.

          Andreas Pieber made changes -
          Fix Version/s framework-2.0.5 [ 10519 ]
          Fix Version/s framework-2.0.4 [ 10508 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.2.0 [ 10523 ]
          Fix Version/s framework-2.1.0 [ 10489 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.1.1 [ 10522 ]
          Fix Version/s framework-2.0.5 [ 10519 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.1.2 [ 10561 ]
          Fix Version/s framework-2.1.1 [ 10522 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.1.3 [ 10566 ]
          Fix Version/s framework-2.1.2 [ 10561 ]
          Andreas Pieber added a comment -

          we're still waiting for the JNDI bundle release...

          Andreas Pieber made changes -
          Fix Version/s framework-2.3.0 [ 10567 ]
          Fix Version/s framework-2.2.0 [ 10523 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.2.1 [ 10569 ]
          Fix Version/s framework-2.1.3 [ 10566 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.2.2 [ 10574 ]
          Fix Version/s framework-2.2.1 [ 10569 ]
          Felix Mayerhuber added a comment -

          there is now a new JNDI bundle version available (now under vote and not released to central). The tests has been started for that. Problem here is that Karaf itself has a JNDI bundle started, which has the previous version. We have to wait for the next Karaf release for that. Tests with Karaf and the new JNDI bundle are now in progress.

          Andreas Pieber added a comment -

          We cant do this without karaf 3

          Andreas Pieber made changes -
          Fix Version/s framework-2.2.3 [ 10588 ]
          Fix Version/s framework-2.2.2 [ 10574 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.0 [ 10589 ]
          Fix Version/s framework-2.3.0 [ 10567 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.3.1 [ 10593 ]
          Fix Version/s framework-2.2.3 [ 10588 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.3.2 [ 10595 ]
          Fix Version/s framework-2.3.1 [ 10593 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.0 [ 10596 ]
          Fix Version/s framework-2.4.0 [ 10589 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.3.3 [ 10598 ]
          Fix Version/s framework-2.3.2 [ 10595 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.1 [ 10616 ]
          Fix Version/s framework-2.3.3 [ 10598 ]
          Christoph Gritschenberger made changes -
          Fix Version/s framework-2.4.2 [ 10621 ]
          Fix Version/s framework-2.4.1 [ 10616 ]
          Andreas Pieber made changes -
          Assignee Felix Mayerhuber [ arcticwolf ]
          Andreas Pieber added a comment -

          Because of a required karaf upgrade or some major internal/api changes of the OEB we cannot fix those issues now and therefore delegate them to 2.4.3

          Andreas Pieber made changes -
          Fix Version/s framework-2.4.3 [ 10660 ]
          Fix Version/s framework-2.4.2 [ 10621 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.4 [ 10761 ]
          Fix Version/s framework-2.4.3 [ 10660 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.5 [ 10764 ]
          Fix Version/s framework-2.4.4 [ 10761 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.1 [ 10771 ]
          Fix Version/s framework-2.6.0 [ 10763 ]
          Fix Version/s framework-2.5.0 [ 10596 ]
          Fix Version/s framework-2.4.5 [ 10764 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.2 [ 10860 ]
          Fix Version/s framework-2.5.1 [ 10771 ]
          Andreas Pieber made changes -
          Workflow jira [ 12940 ] OpenEngSB Workflow [ 15813 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.2 [ 10860 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.6.0 [ 10763 ]
          Stefan Scheiber made changes -
          Assignee Stefan Scheiber [ stfnsche ]
          Richard Mordinyi made changes -
          Priority Critical [ 2 ] Trivial [ 5 ]
          Andreas Pieber added a comment -

          ah OK... I think this should work already again after the upgrade to karaf-RC1.

          Kristof Meixner made changes -
          Assignee Stefan Scheiber [ stfnsche ] Kristof Meixner [ mercynary ]
          Stefan Scheiber made changes -
          Workflow OpenEngSB Workflow [ 15813 ] OpenEngSB 2 Workflow [ 20568 ]
          Stefan Scheiber made changes -
          Status Open [ 1 ] Backlog [ 10001 ]
          Kristof Meixner made changes -
          Status Backlog [ 10001 ] Open [ 1 ]
          Kristof Meixner made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Kristof Meixner added a comment -

          Changed feature definition and version range there.

          Kristof Meixner made changes -
          Status In Progress [ 3 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Stefan Scheiber made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Fix Version/s openengsb-3.0.0.M2 [ 11165 ]
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Assignee Time in statuses
          Felix Mayerhuber
          The issue is open and ready for the assignee to start work on it.Open
          21/Sep/11 11:06 - 18/Feb/12 21:45 : 3611 h, 39 m
          Total: 3611 h, 39 m
          Kristof Meixner
          The issue is open and ready for the assignee to start work on it.Open
          29/Apr/14 14:21 - 30/Apr/14 12:45 : 22 h, 24 m
          25/May/14 13:05 - 25/May/14 13:05 : 14 s
          Total: 22 h, 24 m
          This issue is being actively worked on at the moment by the assignee.In Progress
          25/May/14 13:05 - 25/May/14 13:06 : 1 m
          Total: 1 m
          A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
          25/May/14 13:06 - 11/Jul/14 10:20 : 1125 h, 14 m
          Total: 1125 h, 14 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          11/Jul/14 10:20 - Today 10:00 : 28127 h, 39 m
          Total: 28127 h, 39 m
          The issue is open but not planned to be resolved in the near futureBacklog
          30/Apr/14 12:45 - 25/May/14 13:05 : 600 h, 20 m
          Total: 600 h, 20 m
          Stefan Scheiber
          The issue is open and ready for the assignee to start work on it.Open
          24/May/13 14:59 - 29/Apr/14 14:21 : 8159 h, 22 m
          Total: 8159 h, 22 m
          unknown
          The issue is open and ready for the assignee to start work on it.Open
          05/Sep/11 21:33 - 21/Sep/11 11:06 : 373 h, 32 m
          18/Feb/12 21:45 - 24/May/13 14:59 : 11056 h, 13 m
          Total: 11429 h, 46 m
          Status Time from assignees
          The issue is open and ready for the assignee to start work on it.Open
          Felix Mayerhuber
          21/Sep/11 11:06 - 18/Feb/12 21:45 : 3611 h, 39 m
          Total: 3611 h, 39 m
          Kristof Meixner
          29/Apr/14 14:21 - 30/Apr/14 12:45 : 22 h, 24 m
          25/May/14 13:05 - 25/May/14 13:05 : 14 s
          Total: 22 h, 24 m
          Stefan Scheiber
          24/May/13 14:59 - 29/Apr/14 14:21 : 8159 h, 22 m
          Total: 8159 h, 22 m
          unknown
          05/Sep/11 21:33 - 21/Sep/11 11:06 : 373 h, 32 m
          18/Feb/12 21:45 - 24/May/13 14:59 : 11056 h, 13 m
          Total: 11429 h, 46 m
          This issue is being actively worked on at the moment by the assignee.In Progress
          Kristof Meixner
          25/May/14 13:05 - 25/May/14 13:06 : 1 m
          Total: 1 m
          A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
          Kristof Meixner
          25/May/14 13:06 - 11/Jul/14 10:20 : 1125 h, 14 m
          Total: 1125 h, 14 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          Kristof Meixner
          11/Jul/14 10:20 - Today 10:00 : 28127 h, 39 m
          Total: 28127 h, 39 m
          The issue is open but not planned to be resolved in the near futureBacklog
          Kristof Meixner
          30/Apr/14 12:45 - 25/May/14 13:05 : 600 h, 20 m
          Total: 600 h, 20 m

            People

            • Assignee:
              Kristof Meixner
              Reporter:
              Andreas Pieber
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: