Details

      Description

      It seams that we've introduced some shit here

      [pieber@prime openengsb-framework]$ ./etc/scripts/pre-push.sh 
      Invoking openengsb-maven-plugin
      [INFO] Scanning for projects...
      [WARNING] 
      [WARNING] Some problems were encountered while building the effective model for org.openengsb:openengsb-shared-settings:pom:2.2.0-SNAPSHOT
      [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.aspectj:com.springsource.org.aspectj.weaver:jar -> duplicate declaration of version ${aspectj.version} @ line 634, column 19
      [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.springframework.security:spring-security-config:jar -> duplicate declaration of version ${spring.security.version} @ line 842, column 19
      [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.springframework.security:spring-security-core:jar -> duplicate declaration of version ${spring.security.version} @ line 847, column 19
      [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.springframework.security:spring-security-web:jar -> duplicate declaration of version ${spring.security.version} @ line 880, column 19
      [WARNING] 
      [WARNING] Some problems were encountered while building the effective model for org.openengsb:openengsb-bundle-settings:pom:2.2.0-SNAPSHOT
      [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.aspectj:com.springsource.org.aspectj.weaver:jar -> duplicate declaration of version ${aspectj.version} @ org.openengsb:openengsb-shared-settings:2.2.0-SNAPSHOT, /home/pieber/projects/openengsb-framework/parents/shared/pom.xml, line 634, column 19
      [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.springframework.security:spring-security-config:jar -> duplicate declaration of version ${spring.security.version} @ org.openengsb:openengsb-shared-settings:2.2.0-SNAPSHOT, /home/pieber/projects/openengsb-framework/parents/shared/pom.xml, line 842, column 19
      [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.springframework.security:spring-security-core:jar -> duplicate declaration of version ${spring.security.version} @ org.openengsb:openengsb-shared-settings:2.2.0-SNAPSHOT, /home/pieber/projects/openengsb-framework/parents/shared/pom.xml, line 847, column 19
      [WARNING] 'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.springframework.security:spring-security-web:jar -> duplicate declaration of version ${spring.security.version} @ org.openengsb:openengsb-shared-settings:2.2.0-SNAPSHOT, /home/pieber/projects/openengsb-framework/parents/shared/pom.xml, line 880, column 19
      [WARNING] 
      [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
      [WARNING] 
      [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.

        Gliffy Diagrams

        Error rendering 'com.meetme.plugins.jira.gerrit-plugin:gerritreviewsmodule'. Please contact your JIRA administrators.

          Activity

          There are no comments yet on this issue.

            People

            • Assignee:
              Andreas Pieber
              Reporter:
              Andreas Pieber
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: