OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-2463

TestClient: Inputfield for parameter is not displayed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: framework-2.2.2, framework-2.3.0, openengsb-3.0.0
    • Fix Version/s: openengsb-3.0.0.M1
    • Component/s: framework
    • Labels:

      Description

      In the TestClient it is possible to call Methods for testing.
      For some Parameters in some Methods there is no Inputfield displayed, which leads to an error if method is called.

      The author suggests the following source of the problem after some testing:
      In org.openengsb.ui.admin.testClient.TestClient the inputfields are created in the function populateArgumentList().
      For each argument a org.openengsb.ui.admin.methodArgumentPanel.MethodArgumentPanel is created.
      In the constructor of org.openengsb.ui.admin.methodArgumentPanel.MethodArgumentPanel a org.openengsb.ui.common.editor.BeanEditorPanel is added (depending on the class of the parameter).
      In the constructor of org.openengsb.ui.common.editor.BeanEditorPanel for each attribute a field is created.
      The problem is that the functioncall MethodUtil.buildAttributesList(type); returns an empty list, therefore no field ist created.

        Gliffy Diagrams

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Christoph Prybila created issue -
          Andreas Pieber made changes -
          Field Original Value New Value
          Fix Version/s framework-2.2.2 [ 10574 ]
          Fix Version/s framework-2.3.0 [ 10567 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Andreas Pieber added a comment -

          mhm... since you've already a quite detailed idea of this problem... do you want to provide a patch?

          Andreas Pieber made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Felix Mayerhuber added a comment -

          IMHO that one isn't fixed? Andi, haven't we discussed about it when walking to the subway?

          Felix Mayerhuber added a comment -

          ASFAIK you have fixed OPENENGSB-2464, which is on status in progress

          Andreas Pieber added a comment -

          oha... true

          Andreas Pieber made changes -
          Resolution Fixed [ 1 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Andreas Pieber added a comment -

          this one is a really heavy one since it also requires additional features at various places. We need a way to find out which classes implement the real interface behind, and propose them to the users first; before we can create the bean-classes to enter the data...

          Andreas Pieber made changes -
          Fix Version/s framework-2.2.2 [ 10574 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.4.0 [ 10589 ]
          Fix Version/s framework-2.3.0 [ 10567 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.0 [ 10596 ]
          Fix Version/s framework-2.4.0 [ 10589 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.1 [ 10771 ]
          Fix Version/s framework-2.6.0 [ 10763 ]
          Fix Version/s framework-2.5.0 [ 10596 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.2 [ 10860 ]
          Fix Version/s framework-2.5.1 [ 10771 ]
          Andreas Pieber made changes -
          Assignee Andreas Pieber [ pieber ]
          Andreas Pieber made changes -
          Status Reopened [ 4 ] In Progress [ 3 ]
          Andreas Pieber made changes -
          Status In Progress [ 3 ] Open [ 1 ]
          Andreas Pieber made changes -
          Workflow jira [ 13596 ] OpenEngSB Workflow [ 15885 ]
          Andreas Pieber made changes -
          Rank Ranked lower
          Andreas Pieber made changes -
          Fix Version/s framework-2.5.2 [ 10860 ]
          Andreas Pieber made changes -
          Fix Version/s framework-2.6.0 [ 10763 ]
          Andreas Pieber added a comment -

          this had been fixed quite some time ago already

          Andreas Pieber made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Stefan Scheiber made changes -
          Workflow OpenEngSB Workflow [ 15885 ] OpenEngSB 2 Workflow [ 23112 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Stefan Scheiber made changes -
          Affects Version/s openengsb-3.0.0 [ 10169 ]
          Affects Version/s framework-3.0.0 [ 10488 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0.M1 [ 11164 ]
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Assignee Time in statuses
          Andreas Pieber
          The issue is open and ready for the assignee to start work on it.Open
          11/Jul/12 9:14 - 17/Apr/13 16:01 : 6726 h, 46 m
          Total: 6726 h, 46 m
          This issue is being actively worked on at the moment by the assignee.In Progress
          11/Jul/12 9:14 - 11/Jul/12 9:14 : 3 s
          Total: 3 s
          This issue was once resolved, but the resolution was deemed incorrect. From here issues are either marked assigned or resolved.Reopened
          11/Jul/12 9:14 - 11/Jul/12 9:14 : 2 s
          Total: 2 s
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          17/Apr/13 16:01 - Today 1:02 : 40330 h, 45 s
          Total: 40330 h, 45 s
          unknown
          The issue is open and ready for the assignee to start work on it.Open
          24/Dec/11 15:09 - 28/Dec/11 16:02 : 96 h, 52 m
          Total: 96 h, 52 m
          This issue was once resolved, but the resolution was deemed incorrect. From here issues are either marked assigned or resolved.Reopened
          29/Dec/11 5:46 - 11/Jul/12 9:14 : 4682 h, 28 m
          Total: 4682 h, 28 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          28/Dec/11 16:02 - 29/Dec/11 5:46 : 13 h, 44 m
          Total: 13 h, 44 m
          Status Time from assignees
          The issue is open and ready for the assignee to start work on it.Open
          Andreas Pieber
          11/Jul/12 9:14 - 17/Apr/13 16:01 : 6726 h, 46 m
          Total: 6726 h, 46 m
          unknown
          24/Dec/11 15:09 - 28/Dec/11 16:02 : 96 h, 52 m
          Total: 96 h, 52 m
          This issue is being actively worked on at the moment by the assignee.In Progress
          Andreas Pieber
          11/Jul/12 9:14 - 11/Jul/12 9:14 : 3 s
          Total: 3 s
          This issue was once resolved, but the resolution was deemed incorrect. From here issues are either marked assigned or resolved.Reopened
          Andreas Pieber
          11/Jul/12 9:14 - 11/Jul/12 9:14 : 2 s
          Total: 2 s
          unknown
          29/Dec/11 5:46 - 11/Jul/12 9:14 : 4682 h, 28 m
          Total: 4682 h, 28 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          Andreas Pieber
          17/Apr/13 16:01 - Today 1:02 : 40330 h, 45 s
          Total: 40330 h, 45 s
          unknown
          28/Dec/11 16:02 - 29/Dec/11 5:46 : 13 h, 44 m
          Total: 13 h, 44 m

            People

            • Assignee:
              Andreas Pieber
              Reporter:
              Christoph Prybila
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: