OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-2684

TestClient: Input with wrong Format causes Exception during MethodCall

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: framework-2.2.2, framework-2.3.0, openengsb-3.0.0
    • Fix Version/s: openengsb-3.0.0.M1
    • Component/s: framework
    • Labels:
    • Sprint:
      Sprint 1

      Description

      If you call a Method via the Testclient with Input of inkorrect Format an exception is thrown.
      The Error in org.openengsb.ui.admin.testClient.TestClient originates from the function call "call.getArgumentsAsArray()".

      Replay of error:
      1) Install the example domain via features:install openengsb-connector-example
      2) Create a new Logging Service in the example Domain
      3) Choose new example domain in tree -> choose method doSomethingWithLogEvent(org.openengsb.domain.example.event.LogEvent) in Dropdown
      4) Input in Fields

      Field Input

      level INFO
      message message
      name name
      origin origin
      processId processId (this must be an integer)

      5)call the Method

      This gets you:
      java.lang.IllegalArgumentException: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
      at org.openengsb.ui.common.util.MethodUtil.buildBean(MethodUtil.java:127)[181:org.openengsb.ui.common:3.0.0.SNAPSHOT]
      at org.openengsb.ui.admin.model.Argument.toValue(Argument.java:79)[182:org.openengsb.ui.admin:3.0.0.SNAPSHOT]
      at org.openengsb.ui.admin.model.MethodCall.getArgumentsAsArray(MethodCall.java:57)[182:org.openengsb.ui.admin:3.0.0.SNAPSHOT]
      at org.openengsb.ui.admin.testClient.TestClient.performCall(TestClient.java:648)[182:org.openengsb.ui.admin:3.0.0.SNAPSHOT]
      at org.openengsb.ui.admin.testClient.TestClient$5.onSubmit(TestClient.java:242)[182:org.openengsb.ui.admin:3.0.0.SNAPSHOT]
      at org.apache.wicket.ajax.markup.html.form.AjaxButton$1.onSubmit(AjaxButton.java:101)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.ajax.form.AjaxFormSubmitBehavior.onEvent(AjaxFormSubmitBehavior.java:156)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.ajax.AjaxEventBehavior.respond(AjaxEventBehavior.java:177)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.ajax.AbstractDefaultAjaxBehavior.onRequest(AbstractDefaultAjaxBehavior.java:302)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.request.target.component.listener.BehaviorRequestTarget.processEvents(BehaviorRequestTarget.java:157)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.request.AbstractRequestCycleProcessor.processEvents(AbstractRequestCycleProcessor.java:92)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.RequestCycle.processEventsAndRespond(RequestCycle.java:1252)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.RequestCycle.step(RequestCycle.java:1331)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.RequestCycle.steps(RequestCycle.java:1438)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.RequestCycle.request(RequestCycle.java:546)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:486)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.apache.wicket.protocol.http.WicketServlet.doPost(WicketServlet.java:160)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:713)[58:org.apache.geronimo.specs.geronimo-servlet_2.5_spec:1.1.2]
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:806)[58:org.apache.geronimo.specs.geronimo-servlet_2.5_spec:1.1.2]
      at org.ops4j.pax.wicket.internal.FilterDelegator$Chain.doFilter(FilterDelegator.java:75)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:369)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.invoke(FilterSecurityInterceptor.java:109)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.access.intercept.FilterSecurityInterceptor.doFilter(FilterSecurityInterceptor.java:83)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.access.ExceptionTranslationFilter.doFilter(ExceptionTranslationFilter.java:97)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.session.SessionManagementFilter.doFilter(SessionManagementFilter.java:100)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.authentication.AnonymousAuthenticationFilter.doFilter(AnonymousAuthenticationFilter.java:78)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.servletapi.SecurityContextHolderAwareRequestFilter.doFilter(SecurityContextHolderAwareRequestFilter.java:54)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.savedrequest.RequestCacheAwareFilter.doFilter(RequestCacheAwareFilter.java:35)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.authentication.www.BasicAuthenticationFilter.doFilter(BasicAuthenticationFilter.java:177)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.authentication.ui.DefaultLoginPageGeneratingFilter.doFilter(DefaultLoginPageGeneratingFilter.java:91)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.authentication.AbstractAuthenticationProcessingFilter.doFilter(AbstractAuthenticationProcessingFilter.java:187)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.authentication.logout.LogoutFilter.doFilter(LogoutFilter.java:105)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.context.SecurityContextPersistenceFilter.doFilter(SecurityContextPersistenceFilter.java:79)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy$VirtualFilterChain.doFilter(FilterChainProxy.java:381)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.springframework.security.web.FilterChainProxy.doFilter(FilterChainProxy.java:168)[115:org.springframework.security.web:3.0.7.RELEASE]
      at org.openengsb.ui.common.util.DelegatingSecurityFilter.doFilter(DelegatingSecurityFilter.java:42)[181:org.openengsb.ui.common:3.0.0.SNAPSHOT]
      at org.ops4j.pax.wicket.internal.FilterDelegator$Chain.doFilter(FilterDelegator.java:73)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.openengsb.ui.common.util.ContextIdFilter.doFilter(ContextIdFilter.java:67)[181:org.openengsb.ui.common:3.0.0.SNAPSHOT]
      at org.ops4j.pax.wicket.internal.FilterDelegator$Chain.doFilter(FilterDelegator.java:73)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.ops4j.pax.wicket.internal.FilterDelegator.doFilter(FilterDelegator.java:57)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.ops4j.pax.wicket.internal.ServletProxy$ServletInvocationHandler.invoke(ServletProxy.java:80)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at $Proxy116.service(Unknown Source)[179:org.ops4j.pax.wicket.pax-wicket-service:0.7.5]
      at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:538)[69:org.eclipse.jetty.servlet:7.4.5.v20110725]
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:478)[69:org.eclipse.jetty.servlet:7.4.5.v20110725]
      at org.ops4j.pax.web.service.jetty.internal.HttpServiceServletHandler.doHandle(HttpServiceServletHandler.java:70)[78:org.ops4j.pax.web.pax-web-jetty:1.0.7]
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:517)[68:org.eclipse.jetty.security:7.4.5.v20110725]
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:225)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:937)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.ops4j.pax.web.service.jetty.internal.HttpServiceContext.doHandle(HttpServiceContext.java:116)[78:org.ops4j.pax.web.pax-web-jetty:1.0.7]
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:406)[69:org.eclipse.jetty.servlet:7.4.5.v20110725]
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:871)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.ops4j.pax.web.service.jetty.internal.JettyServerHandlerCollection.handle(JettyServerHandlerCollection.java:72)[78:org.ops4j.pax.web.pax-web-jetty:1.0.7]
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:110)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.server.Server.handle(Server.java:346)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:589)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.server.HttpConnection$RequestHandler.content(HttpConnection.java:1065)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:823)[63:org.eclipse.jetty.http:7.4.5.v20110725]
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:220)[63:org.eclipse.jetty.http:7.4.5.v20110725]
      at org.eclipse.jetty.server.HttpConnection.handle(HttpConnection.java:411)[67:org.eclipse.jetty.server:7.4.5.v20110725]
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:535)[62:org.eclipse.jetty.io:7.4.5.v20110725]
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:40)[62:org.eclipse.jetty.io:7.4.5.v20110725]
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:529)[61:org.eclipse.jetty.util:7.4.5.v20110725]
      at java.lang.Thread.run(Thread.java:722)[:1.7.0_01]
      Caused by: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException
      at org.openengsb.ui.common.util.MethodUtil.convertToCorrectClass(MethodUtil.java:227)[181:org.openengsb.ui.common:3.0.0.SNAPSHOT]
      at org.openengsb.ui.common.util.MethodUtil.buildBean(MethodUtil.java:122)[181:org.openengsb.ui.common:3.0.0.SNAPSHOT]
      ... 75 more
      Caused by: java.lang.reflect.InvocationTargetException
      at sun.reflect.GeneratedConstructorAccessor77.newInstance(Unknown Source)[:1.7.0_01]
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)[:1.7.0_01]
      at java.lang.reflect.Constructor.newInstance(Constructor.java:525)[:1.7.0_01]
      at org.openengsb.ui.common.util.MethodUtil.convertToCorrectClass(MethodUtil.java:219)[181:org.openengsb.ui.common:3.0.0.SNAPSHOT]
      ... 76 more
      Caused by: java.lang.NumberFormatException: For input string: "processId"
      at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)[:1.7.0_01]
      at java.lang.Long.parseLong(Long.java:441)[:1.7.0_01]
      at java.lang.Long.<init>(Long.java:702)[:1.7.0_01]
      ... 80 more

        Gliffy Diagrams

        Error rendering 'com.meetme.plugins.jira.gerrit-plugin:gerritreviewsmodule'. Please contact your JIRA administrators.

          Activity

          Andreas Pieber added a comment -

          Because of a required karaf upgrade or some major internal/api changes of the OEB we cannot fix those issues now and therefore delegate them to 2.4.3


            People

            • Assignee:
              Felix Mayerhuber
              Reporter:
              Christoph Prybila
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile