OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-2725

pax wicket throws classcast exception during authentification in admin ui unittests

    Details

      Description

      The unit tests extending AbstractLoginTest using the method mockAuthentication() throw an ClassCastException at

      public static AuthenticatedWebSession get()
      {
      return (AuthenticatedWebSession)Session.get();
      }

      because Session.get() returns an org.apache.wicket.protocol.http.WebSession instead of an org.apache.wicket.authentication.AuthenticatedWebSession

        Gliffy Diagrams

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Lukas Stampf created issue -
          Lukas Stampf added a comment -

          You will need OPENENGSB-2724 to make the tests runnable.

          Andreas Pieber added a comment -

          this one is only a problem of the master

          Andreas Pieber made changes -
          Field Original Value New Value
          Fix Version/s framework-3.0.0 [ 10488 ]
          Fix Version/s framework-2.4.2 [ 10621 ]
          Affects Version/s framework-3.0.0 [ 10488 ]
          Affects Version/s framework-2.4.1 [ 10616 ]
          Andreas Pieber made changes -
          Status Open [ 1 ] In Progress [ 3 ]
          Andreas Pieber made changes -
          Status In Progress [ 3 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Andreas Pieber made changes -
          Workflow jira [ 14052 ] OpenEngSB Workflow [ 18553 ]
          Andreas Pieber made changes -
          Labels archived
          Stefan Scheiber made changes -
          Workflow OpenEngSB Workflow [ 18553 ] OpenEngSB 2 Workflow [ 23347 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Stefan Scheiber made changes -
          Affects Version/s openengsb-3.0.0 [ 10169 ]
          Affects Version/s framework-3.0.0 [ 10488 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0.M1 [ 11164 ]
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Assignee Time in statuses
          Andreas Pieber
          The issue is open and ready for the assignee to start work on it.Open
          06/Feb/12 18:32 - 08/Feb/12 9:50 : 39 h, 18 m
          Total: 39 h, 18 m
          This issue is being actively worked on at the moment by the assignee.In Progress
          08/Feb/12 9:50 - 08/Feb/12 9:51 : 1 m
          Total: 1 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          08/Feb/12 9:51 - Today 17:04 : 49878 h, 12 m
          Total: 49878 h, 12 m
          Status Time from assignees
          The issue is open and ready for the assignee to start work on it.Open
          Andreas Pieber
          06/Feb/12 18:32 - 08/Feb/12 9:50 : 39 h, 18 m
          Total: 39 h, 18 m
          This issue is being actively worked on at the moment by the assignee.In Progress
          Andreas Pieber
          08/Feb/12 9:50 - 08/Feb/12 9:51 : 1 m
          Total: 1 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          Andreas Pieber
          08/Feb/12 9:51 - Today 17:04 : 49878 h, 12 m
          Total: 49878 h, 12 m

            People

            • Assignee:
              Andreas Pieber
              Reporter:
              Lukas Stampf
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: