OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-3178

Remove DomainEventsProxyFactoryBean from framework-common

    Details

    • Changelog:
      You must use the auto-injection of domain-services
      Add the following fields to your MANIFEST.MF:
      * Domain-Name: example
      * Domain-Interface: org.openengsb.domain.example.ExampleDomain
      * DomainEvents-Interface: org.openengsb.domain.example.ExampleDomainEvents
      Show
      You must use the auto-injection of domain-services Add the following fields to your MANIFEST.MF: * Domain-Name: example * Domain-Interface: org.openengsb.domain.example.ExampleDomain * DomainEvents-Interface: org.openengsb.domain.example.ExampleDomainEvents
    • Sprint:
      Sprint 4

      Description

      It's not required anymore since OPENENGSB-3136 is fixed.

        Gliffy Diagrams

        No reviews matched the request. Check your Options in the drop-down menu of this sections header.

          Activity

          Christoph Gritschenberger created issue -
          Christoph Gritschenberger made changes -
          Field Original Value New Value
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Fixed [ 1 ]
          Christoph Gritschenberger added a comment -

          It's a little odd to deprecate this on 2.x.y as there is no alternative in 2.x.y

          Christoph Gritschenberger made changes -
          Changelog You must use the auto-injection of domain-services
          Add the following fields to your MANIFEST.MF:
          * Domain-Name: example
          * Domain-Interface: org.openengsb.domain.example.ExampleDomain
          * DomainEvents-Interface: org.openengsb.domain.example.ExampleDomainEvents
          Christoph Gritschenberger made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Andreas Pieber made changes -
          Workflow jira [ 15040 ] OpenEngSB Workflow [ 18910 ]
          Andreas Pieber made changes -
          Labels archived
          Stefan Scheiber made changes -
          Issue Type Refactoring [ 13 ] Improvement [ 4 ]
          Stefan Scheiber made changes -
          Workflow OpenEngSB Workflow [ 18910 ] OpenEngSB 2 Workflow [ 23734 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Fix Version/s framework-3.0.0 [ 10488 ]
          Stefan Scheiber made changes -
          Fix Version/s openengsb-3.0.0.M1 [ 11164 ]
          Fix Version/s openengsb-3.0.0 [ 10169 ]
          Assignee Time in statuses
          Christoph Gritschenberger
          The issue is open and ready for the assignee to start work on it.Open
          26/Jul/12 17:47 - 26/Jul/12 18:17 : 29 m
          Total: 29 m
          A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
          26/Jul/12 18:17 - 30/Jul/12 19:02 : 96 h, 44 m
          Total: 96 h, 44 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          30/Jul/12 19:02 - Today 9:55 : 47991 h, 52 m
          Total: 47991 h, 52 m
          Status Time from assignees
          The issue is open and ready for the assignee to start work on it.Open
          Christoph Gritschenberger
          26/Jul/12 17:47 - 26/Jul/12 18:17 : 29 m
          Total: 29 m
          A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
          Christoph Gritschenberger
          26/Jul/12 18:17 - 30/Jul/12 19:02 : 96 h, 44 m
          Total: 96 h, 44 m
          The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
          Christoph Gritschenberger
          30/Jul/12 19:02 - Today 9:55 : 47991 h, 52 m
          Total: 47991 h, 52 m

            People

            • Assignee:
              Christoph Gritschenberger
              Reporter:
              Christoph Gritschenberger
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Agile