OpenEngSB
  1. OpenEngSB
  2. OPENENGSB-3197

Move AbstractDataRow to EDB and rename it to something meaningful

    Details

    • Changelog:
      The AbstractDataRow is no longer publicly available. It has been moved to edb.jpa.internal
    • Sprint:
      Sprint 7, Sprint 8

      Gliffy Diagrams

      Error rendering 'com.meetme.plugins.jira.gerrit-plugin:gerritreviewsmodule'. Please contact your JIRA administrators.

        Activity

        Christoph Gritschenberger created issue -
        Felix Mayerhuber added a comment -

        Maybe I'm the wrong here, but wasn't the sense of the AbstractDataRow that it doesn't only affect the EDB but the JPA persistence? At least I think Lukas told so.

        Christoph Gritschenberger added a comment -

        Well every Entity is derived from it. But it doesn't make sense anywhere except in the EDB.

        Felix Mayerhuber added a comment -

        Hmm ... isn't it rather common then? Because the AbstractDataRow is intended to JPA AFAIK and the EDB isn't required to be implemented with JPA

        Christoph Gritschenberger added a comment -

        That's exactly why it belongs in the edb-bundle. The edb-api (org.openengsb.framework.edb.api) does not specify such a class.
        the impl-bundle (org.openengsb.framework.edb.jpa) implements the API using JPA and thus should contain said class.

        Felix Mayerhuber added a comment -

        But if someone things about replacing the edb.jpa with say edb.file this class wouldn't be present any more for all other parts of the OpenEngSB where it is needed?

        Christoph Gritschenberger added a comment -

        I actually intended to remove all other references to that class.

        Lukas Stampf added a comment -

        Andis idea behind the AbstractDataRow was to have a base class for every JPA Entity, so each entity has some common fields, like created, version and a global unique id which can be useful sometimes. So I think moving the class to a specific bundle like the EDB contradicts this idea, no use to have an abstract base class just for one bundle.

        Andreas Pieber added a comment -

        well, why not deleting it completely then as an alternative?

        Christoph Gritschenberger added a comment -

        And move its functionality to EDB-entity(ies) directly. Fine with me.

        Felix Mayerhuber added a comment -

        if we don't need the functionality in all entities, then merging it with EDB entities is probably the best approach

        Christoph Gritschenberger made changes -
        Field Original Value New Value
        Rank Ranked higher
        Christoph Gritschenberger made changes -
        Assignee Christoph Gritschenberger [ christophg ]
        Christoph Gritschenberger made changes -
        Sprint Sprint 7 [ 7 ]
        Christoph Gritschenberger made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Andreas Pieber made changes -
        Sprint Sprint 7 [ 7 ] Sprint 7, Sprint 8 [ 7, 8 ]
        Christoph Gritschenberger made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Changelog The AbstractDataRow is no longer publicly available. It has been moved to edb.jpa.internal
        Resolution Fixed [ 1 ]
        Christoph Gritschenberger made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Andreas Pieber made changes -
        Workflow jira [ 15145 ] OpenEngSB Workflow [ 18925 ]
        Andreas Pieber made changes -
        Labels archived
        Stefan Scheiber made changes -
        Issue Type Refactoring [ 13 ] Improvement [ 4 ]
        Stefan Scheiber made changes -
        Workflow OpenEngSB Workflow [ 18925 ] OpenEngSB 2 Workflow [ 23750 ]
        Stefan Scheiber made changes -
        Fix Version/s openengsb-3.0.0 [ 10169 ]
        Fix Version/s framework-3.0.0 [ 10488 ]
        Stefan Scheiber made changes -
        Fix Version/s openengsb-3.0.0.M1 [ 11164 ]
        Fix Version/s openengsb-3.0.0 [ 10169 ]
        Assignee Time in statuses
        Christoph Gritschenberger
        The issue is open and ready for the assignee to start work on it.Open
        22/Aug/12 13:48 - 29/Aug/12 16:37 : 170 h, 49 m
        Total: 170 h, 49 m
        This issue is being actively worked on at the moment by the assignee.In Progress
        29/Aug/12 16:37 - 05/Sep/12 18:05 : 169 h, 27 m
        Total: 169 h, 27 m
        A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
        05/Sep/12 18:05 - 05/Sep/12 18:06 : 59 s
        Total: 59 s
        The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
        05/Sep/12 18:06 - Today 9:58 : 50679 h, 52 m
        Total: 50679 h, 52 m
        unknown
        The issue is open and ready for the assignee to start work on it.Open
        30/Jul/12 16:53 - 22/Aug/12 13:48 : 548 h, 55 m
        Total: 548 h, 55 m
        Status Time from assignees
        The issue is open and ready for the assignee to start work on it.Open
        Christoph Gritschenberger
        22/Aug/12 13:48 - 29/Aug/12 16:37 : 170 h, 49 m
        Total: 170 h, 49 m
        unknown
        30/Jul/12 16:53 - 22/Aug/12 13:48 : 548 h, 55 m
        Total: 548 h, 55 m
        This issue is being actively worked on at the moment by the assignee.In Progress
        Christoph Gritschenberger
        29/Aug/12 16:37 - 05/Sep/12 18:05 : 169 h, 27 m
        Total: 169 h, 27 m
        A resolution has been taken, and it is awaiting verification by reporter. From here issues are either reopened, or are closed.Resolved
        Christoph Gritschenberger
        05/Sep/12 18:05 - 05/Sep/12 18:06 : 59 s
        Total: 59 s
        The issue is considered finished, the resolution is correct. Issues which are closed can be reopened.Closed
        Christoph Gritschenberger
        05/Sep/12 18:06 - Today 9:58 : 50679 h, 52 m
        Total: 50679 h, 52 m

          People

          • Assignee:
            Christoph Gritschenberger
            Reporter:
            Christoph Gritschenberger
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Agile